Labošanas kļūda: Šķiet, ka jūsu PHP instalācijā trūkst MySQL paplašinājuma, kuru pieprasa WordPress

"Šķiet, ka jūsu PHP instalācijā trūkst MySQL paplašinājuma, kuru pieprasa WordPress"Vai kļūda ir daudziem emuāru īpašniekiem un vietnēm WordPress.
Tas nerada bažas. MySQL paplašinājuma trūkums no PHP ir tipisks operētājsistēmām, kas instalētas no jauna, VPS vai speciālajiem serveriem, kur PHP paplašinājumi nebija instalēšanas paketes sastāvdaļa. Šī problēma pastāv abos gadījumos Ubuntu un CentOS. Šajā scenārijā problēma tiek atrisināta ļoti vienkārši ar PHP atjaunināšanu un moduļa instalēšanu "php-mysql".
Atjauniniet PHP un instalējiet MySQL paplašinājumu Ubuntu

apt-get update
apt-get install php-mysql

Atjauniniet PHP un instalējiet MySQL paplašinājumu uz CentOS

yum update
yum install php70w-mysql

Pēc šī soļa restartējiet Apache pakalpojumu vai nginx.

Es saskāros arī ar scenāriju, kurā, kaut arī MySQL paplašinājums pastāv PHP, WordPress izveidotā emuārā tika parādīta kļūda "Šķiet, ka jūsu PHP instalācijā trūkst MySQL paplašinājuma, kuru pieprasa WordPress". Lielākoties kļūda rodas, instalējot WordPress. Tomēr šoreiz viņš parādījās emuārā, kas bija aktīvs vairākus gadus.
Šajā situācijā es atklāju, ka problēma nav PHP moduļos, bet gan ļoti vecajā WordPress versijā, kas vairs nav savietojama ar PHP 7.4.4RC1. Kļūdu atrisināja vienkāršs WordPress jauninājums uz jaunāko versiju.

Labošanas kļūda: Šķiet, ka jūsu PHP instalācijā trūkst MySQL paplašinājuma, kuru pieprasa WordPress

Par autoru

Maskēšanās

Kaislīgi pret visu, kas nozīmē sīkrīku un IT, es ar prieku rakstu vietnē stealthsettings.com no 2006 un man patīk atklāt jaunas lietas par datoriem un macOS, Linux operētājsistēmām, Windows, iOS un Android.

Leave a Comment